Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Fusion calque de réglage
#1
Bonjour,

Résumé du problème :

1 - Sur une image en niveaux de gris 16 bits, j'ajoute un calque de réglage des calques.
2 - Ce paramètre devient inopérant lors de la fusion ou de l'exportation dans un format qui aplatit.

Quelqu'un a-t-il une idée?

Je vous remercie.
Vos applications :
  • > Affinity Photo Windows
  • > Affinity Designer Windows
  • > Affinity Publisher Windows
#2
Bin non — je veux dire que tout se passe bien sous ma souris.

Essaie de nous montrer une pièce à conviction, une image pas trop grosse qui ne veut pas obéir à ce que tu lui demandes, et mets-la en ligne pour qu'on la voie de plus près.
#3
Tout se passe bien aussi chez moi qui suis sous windows... donc déjà, ce n'est pas un problème de différence de logiciel en fonction du système d'exploitation...
La règle d'or est la tolérance mutuelle car
nous ne penserons jamais tous de la même façon, nous ne verrons qu'une partie de la vérité et sous des angles différents
Vos applications :
  • > Affinity Photo Windows
#4
Bonsoir

Dans une autre discussion récente , le problème des calques de réglages avait été évoqué
Un CTRL maintenu au reboot d'Affinity Photo peut remettre les choses dans l'ordre en cochant réinitialiser les Réglages
 ■ Canon 6D  alain29  Fuji X30
Vos applications :
  • > Affinity Photo Windows
  • > Affinity Designer Windows
  • > Affinity Publisher Windows
#5
(12-02-19, 22:58:17)Alain29 a écrit : Bonsoir

Dans une autre discussion récente , le problème des calques de réglages avait été évoqué
Un CTRL maintenu au reboot d'Affinity Photo  peut remettre les choses dans l'ordre en cochant réinitialiser les Réglages

Bonsoir Cenphil et Alain29,
Je me suis peut être exprimé incomplètement. Il s'agit d'image particulière composée de lignes tourmentées sur transparence. Lorsque l'on aplatit les calques de réglages l'image s'assombrit et n'est plus conforme aux réglages ajoutés. Idem lorsque l'on fait un export en Tiff par exemple.
Pour en juger au mieux ouvrez le fichier 819.afphoto, mettez le taux de zoom à 100 % (Ctrl + 1) et faites Document → Aplatir.
Esr-ce que vous constatez le même pb que moi ?
Bonne soirée et merci pour la promptitude de vos réponses.
fodratou
[Image: ?id=668665B6CFAC1F4C%213447&cid=668665B6CFAC1F4C]
Vos applications :
  • > Affinity Photo Windows
  • > Affinity Designer Windows
  • > Affinity Publisher Windows
#6
Fichier inaccessible ! OneDrive se plaint d'avoir rencontré un problème... Tu peux essayer de le mettre sur https://www.cjoint.com (s'il fait moins de 15 Mo) et tu nous donnes le lien pour y accéder.
#7
(13-02-19, 11:47:58)ch22 a écrit : Fichier inaccessible ! OneDrive se plaint d'avoir rencontré un problème... Tu peux essayer de le mettre sur https://www.cjoint.com (s'il fait moins de 15 Mo) et tu nous donnes le lien pour y accéder.

Voici le lien en espérant que cela fonctionne.
Bonne journée et encore merci.
fodratou
https://www.cjoint.com/c/IBnkqDsOCvu
Vos applications :
  • > Affinity Photo Windows
  • > Affinity Designer Windows
  • > Affinity Publisher Windows
#8
Wink 
Bien reçu, bien téléchargé... et tout baigne dans l'huile !   [Image: biggrin.png]

Je pense que tu es victime d'un effet de Moiré. Reconstitution (regardez les copies d'écran suivantes à 100%) :

[Image: comparaison.jpg]

(i) Je travaille sur un écran 1920x1200. Effectivement, quand je regarde ton image à 50% d'échelle et que j'aplatis, l'affichage s'assombrit, comme si ton réglage de niveau n'était pas pris en compte. 
(i)Je reviens en arrière (CTRL Z) et  je fais une copie de ton image dans un nouveau calque  (CTRL ALT MAJ E) : même effet d'assombrissement, mais ton image est bien restée inchangée par dessous le calque aplati. Bizarre ? Vous avez dit bizarre ?
(iii) Je passe à 100 % d'échelle et je compare ton image au calque aplati :  miracle, c'est pareil !

Mon interprétation est que quand on affiche une image à moins de 100% d'échelle, il y a évidemment des interpolations pour calculer ce qu'on va mettre dans chacun des pixels de l'écran et que, manifestement, dans le cas d'une image multi-calque, le logiciel ne procède pas au calcul des points de toute l'image composite avant de faire cette interpolation pour son affichage réduit (sinon, le calque aplati serait toujours affiché comme l'image multi-calque). J'imagine qu'il ne fait cette interpolation que pour le premier calque et qu'il calcule ensuite l'effet de chaque réglage sur cette image réduite — ça économise du temps de calcul.  

A 50% d'échelle, on a des effets de moirage dans ton image et ils sont bien plus forts dans l'image multi-calques que dans sa version aplatie, et, dans les deux cas, bien plus forts que quand on observe à 100%

Dernière remarque : on a les mêmes problèmes avec Photoshop, si ça peut consoler [Image: wink.png]
#9
(13-02-19, 14:44:05)ch22 a écrit : Bien reçu, bien téléchargé... et tout baigne dans l'huile !   [Image: biggrin.png]

Je pense que tu es victime d'un effet de Moiré. Reconstitution (regardez les copies d'écran suivantes à 100%) :

[Image: comparaison.jpg]

(i) Je travaille sur un écran 1920x1200. Effectivement, quand je regarde ton image à 50% d'échelle et que j'aplatis, l'affichage s'assombrit, comme si ton réglage de niveau n'était pas pris en compte. 
(i)Je reviens en arrière (CTRL Z) et  je fais une copie de ton image dans un nouveau calque  (CTRL ALT MAJ E) : même effet d'assombrissement, mais ton image est bien restée inchangée par dessous le calque aplati. Bizarre ? Vous avez dit bizarre ?
(iii) Je passe à 100 % d'échelle et je compare ton image au calque aplati :  miracle, c'est pareil !

Mon interprétation est que quand on affiche une image à moins de 100% d'échelle, il y a évidemment des interpolations pour calculer ce qu'on va mettre dans chacun des pixels de l'écran et que, manifestement, dans le cas d'une image multi-calque, le logiciel ne procède pas au calcul des points de toute l'image composite avant de faire cette interpolation pour son affichage réduit (sinon, le calque aplati serait toujours affiché comme l'image multi-calque). J'imagine qu'il ne fait cette interpolation que pour le premier calque et qu'il calcule ensuite l'effet de chaque réglage sur cette image réduite — ça économise du temps de calcul.  

A 50% d'échelle, on a des effets de moirage dans ton image et ils sont bien plus forts dans l'image multi-calques que dans sa version aplatie, et, dans les deux cas, bien plus forts que quand on observe à 100%

Dernière remarque : on a les mêmes problèmes avec Photoshop, si ça peut consoler [Image: wink.png]

Merci ch22, j'avais pensé également à l'effet de moiré, c'est pourquoi j'ai fait mes comparaisons à 100 % (Ctrl + 1) et là, il n'y a pas de doute je pense que le taux de zoom n'est pas en cause. Le plus grave, c'est lorsque l'on exporte en Tiff ou Jpg, le résultat est indiscutablement plus sombres. J'e précise que j'agis dans le cadre d'un atelier réservé à un photographe argentique qui veut retrouver les mêmes techniques qu'il utilisait en argentique.
Merci de la peine que tu t'es donnée et au plaisir de se contacter à nouveau et longue vie à Affinity Photo.
Vos applications :
  • > Affinity Photo Windows
  • > Affinity Designer Windows
  • > Affinity Publisher Windows
#10
Désolé, mais je ne peux que répéter que je ne voie aucun assombrissement quand j'opère à 100%. Pour asseoir cette affirmation :

(1) j'affiche l'image multicalque à 100% et je fais une copie d'écran (mon écran est calibré et cette copie d'écran utilise son profil comme profil colorimétrique) 
(2) j'exporte l'image multicalque en JPEG
(3) prenant Photoshop comme arbitre, je superpose la copie d'écran à l'export JPEG : c'est exactement la même chose.

Ci-dessous ma copie d'écran
[Image: copie-ecran.jpg]
et l'export en JPEG
[Image: export-JPEG.jpg]
C'est le même chose, à ceci près que la copie d'écran ne couvre qu'une partie de l'image
#11
Bonjour

Tu es victime d'un repliement de spectre qui arrive quand une texture est beaucoup plus fine que la profondeur d’échantillonnage ( a la TV quand un homme a un costume pied de poule) mais est quelque part un sous multiple
Il faut donc essayer de monter en fréquence (ici 8 bit)
Je viens d'essayer => RVB 32 bit lineaire puis Gris 16 bit quasiment plus " d'entrelacs" impose donc un tiff 16 bit, voir png 24 bit...
Directement de Gris 8 a 16, mais à voir

Par contre il faut revoir les réglages . Bon j'espère que cela te sauvera
Nikon 610 / Win10  16 go  de  Ram  Affinity Publisher 1.6.4.104
Vos applications :
  • > Affinity Photo Windows
#12
(14-02-19, 10:48:12)Max P a écrit : Bonjour

Tu es victime d'un repliement de spectre qui arrive quand une texture est beaucoup plus fine que la profondeur d’échantillonnage  ( a la TV quand un homme a un costume pied de poule) mais est quelque part un sous multiple
Il faut donc essayer de  monter en fréquence  (ici 8 bit)
Je viens d'essayer => RVB 32 bit lineaire puis Gris 16 bit  quasiment plus " d'entrelacs"  impose donc un tiff 16 bit,  voir png 24 bit...
Directement de Gris 8 a 16,  mais à voir

Par contre il faut revoir les réglages . Bon j'espère que cela te sauvera

J'ai essayé la méthode de Max et effectivement le moiré a disparu et pratiquement plus d'assombrissement. Je vais donc conseiller à mon photographe de travailler en niveaux de gris 16 bits et avec un export en Tiff en 16 bits.
Merci à tous pour votre réactivité et au plaisir.
Bonne soirée
Vos applications :
  • > Affinity Photo Windows
  • > Affinity Designer Windows
  • > Affinity Publisher Windows
  


Atteindre :


Utilisateur(s) parcourant ce sujet :
1 visiteur(s)